Jupyter notebook doesn't open in browser automatically

Hello,
I installed Anaconda 3 and I am trying to open Jupyter Notebook, but nothing happens. When I run command prompt and type “jupyter notebook” that appears (see photo), but browser doesn’t open automatically. What should I do to be able to run it and make it automatically to open a browser?

There are a lot of suggestions for Windows users at https://stackoverflow.com/questions/46829761/how-to-open-jupyter-notebook-in-chrome-on-windows .

Hello, Dear, you problem, How did you solve it?

Hello @fomightez this problem How did you solve it for Linux?

I only use Linux in remote systems. See the links below for some ideas perhaps:

Thank @fomightez for you answer, this my error with Linux RedHat7, the browser not load Jupyter Notebook

Did you register your browser with Jupyter via the config file? I don’t use linux desktop/GUI, and so I cannot test.

Yes @fomightez, I using the remote server, and access is --no-browser, the Jupyter Notebook no canno’t view in the browser IP a from remote computer

Oh. I don’t know if you can expect running on a remote system to open the browser on your local computer automatically. The automatic browser opening stuff I was referencing above (I believe) is when you are working with your notebook server locally. Opening a browser on the remote computer isn’t going to help, and in most cases isn’t going to work.

But maybe by ?What should I do to be able to run it and make it automatically to open a browser?", you instead mean get your local browser to connect to the server on the remote computer?

What I do is after the notebook server is up and running like in the terminal you pasted above in your question, is that I leave that terminal window open so the server continues to run and then open a new terminal window. In the new terminal window, I make an SSH tunnel using the information from the URL and the port I opened on the remote system. Then I open a browser on my local computer and I paste in a URL in my browser to connect to the remote notebook server, like so based on your first post I’d be pasting something like you see on this line below in the URL bar of my local browser after the server is running and the tunnel is established:

http://localhost:8889/?token=507b6da30dbfob167bcd477aa1c85b

I follow along mostly the following when I use AWS EC2:


with the SSH tunnel command actually based on here.

I was having this problem were Centos 8 was running Jupyter Notebook fine, then the next day I could not access it via Chrome on my windows machine. The server ran fine, but the browser timed out. The problem is the Linux firewall, I remebered I disabled it because when I first set this up, it didn’t work so I disabled the firewall. I just did not make the config permanent. And the only configuration I have for Jupyter in it;s config file is the IP address. That is all you need, well unless you log in as root, or just do the --allow-root option.

Excuse me I’ve in big trouble I installed python and jupyter as you shown in video but after typing “jupyter notebook” is not opeing or showing anything and also no error is showing. How to resolve this can anyone plzz tell !