Jupyter notebook browser page not loading

Hello,
I have been using Jupyter Notebook successfully for a long time, but today I have encountered a strange problem. Running on windows 10, if I type jupyter notebook in a command prompt then I see the usual text and startup appears successful.
However, when I try to open jupyter in a browser tab I cannot connect, the page remains blank with the little ‘loading’ icon on the browser tab spining indefinitely.
I have tried opening:
http://localhost:8888/tree or http://127.0.0.1:8888 and have also tried opening via file:///C:/Users/[username]/AppData/Roaming/jupyter/runtime/nbserver-11912-open.html
In the latter case I see the text:
This page should redirect you to Jupyter Notebook. If it doesn't, click here to go to Jupyter.
But jupyter never loads.

I have not changed any system settings since I last ran jupyter successfully. Furthermore, I have tried three browsers (Chrome, Edge, Firefox) and have the same problem on three separate PCs, two of which are Win 10 Enterprise and one is Win 10 Home. I have tried opening ports on the firewall but that doesn’t help. Confusingly, I can connect to a remote notebook fine (via ssh), it’s only loading a local copy of jupyter that’s problematic.

Any ideas what the problem could be? i’ve run out of ideas.
Thanks!

I am relatively new to anaconda and jupyter notebooks and am having the exact same problem running on windows 10. I have tried uninstalling and reinstalling anaconda and jupyter notebook, but the notebook still won’t open on any browser.

Are there other GUIs that can be used to run anaconda environments?
Thanks!

I have fixed this by using jupyter lab instead of jupyter notebook at the command prompt. You can then navitage to localhost:8888/tree to use notebooks as before.

Obviously, though, this is not an optimal solution and the notebooks should work without having to do this, so any proper solutions would be greatly appreciated!

I have nothing to add, except that you are not alone, I have exactly the same problem. I’m on Windows 10, just updated a couple of libraries with conda, and have the same rather frustrating problem.
I have no idea how to debug this. The console where I start jupyter notebook shows nothing whatsoever. The only solution so far (as someone else mentioned) is to start with jupyter lab instead of notebook.
This looks like a bug, but I don’t even know how to start debugging…

FYI, jupyter notebook now works again on one of my machines after doing a conda update --all. I’m not sure what changed, though, as another machine still doesn’t work. Despite having the same lib versions!

1 Like

New member, happy for this resource!

Same experience, long time Win 10 user of Anaconda and Jupyter, till the thinks broke this week.

Has anyone heard of progress on this?

Just cost me a day trying uninstalls and chasing things until I found this thread. Thank you for the JupyterLab command line workaround. Probably the only thing I did NOT think to try, but at least am back on the rails, thanks to this community!

John

1 Like

Good morning.

I am with the same problem here and I tried to do the update, but it didn’t solve the problem.

So, I uninstalled the Anaconda and remove all files on my user directory, and reinstalled it from scratch.

It didn’t work too.

I tried turning off my McAfee antivirus, and its firewall, and didn’t work.

But, I discovered if I call the Jupyter on the browser using the IP address instead of localhost it works.

Then I tested Chrome (I’m using Edge Chromium since 2020) and everything works fine.

Apparently, the Chrome Edge is not resolving the LOCALHOST name or is blocked.

Any idea?

Regards,

Emanuel

1 Like