Jupyter Notebook window won't open after Catalina upgrade

Hi there,
I was happily using Jupyter Notebook via Anaconda Navigator until upgrading to MacOS Catalina late last year. Since then I have tried…

  • reinstalling Navigator via the pkg and command line
  • setting up a conda env

…but to no avail, when I try to run Jupyter Notebook I get a window opening in Chrome (or Firefox or Safari) stuck at “waiting for localhost”. The same issue if I use the localhost URL directly.

Any suggestions gratefully received!
Thanks,
Simon

It sounds like the notebook server is not starting up properly. Try running the command jupyter notebook from command line in Terminal.app - what do you see? If you see a message like:

The Jupyter Notebook is running at:
http://localhost:8888/

then try connecting to that URL. You may need to do this from within your conda env.

Hi @scbarton and many thanks for the response.

Attached is a screenshot of the Terminal window…

…unfortunately if I copy and paste the highlighted link (http://localhost…) I get the same outcome ie a tab in Chrome with a little loading wheel of doom and a message saying “Waiting for localhost…” at the bottom of a blank window.

Hello!

Were you able to solve these issues?
I’m experiencing exactly the same and running out of ideas. My environment is:
macOS Catalina 10.15.3
Anaconda 2019.10
jupyter 1.0.0

And tried to access http://localhost:8888/
in Chrome, Chrome Incognito and Safari without any success.

Any direction would be greatly appreciated!

UPDATE after reinstalling I am able to access via 127.0.0.1:8888/lab
localhost:8888/ is still not resolving, but that’s a different issue.

1 Like

I’m running into this same issue. Unable to access localhost, but by typing in the local IP, I can access my jupyter notebooks. Has anyone else run into this issue?

Exact same setup and versions as @Azucena_Coronel above.

1 Like