JupyterHub-AWS EC2 instance-This site can't be reached

AWS EC2 instance: /hvm-ssd/ubuntu-focal-20.04-amd64-server
Instance Type: C5 large

Tried installing JupyterHub two ways:

  1. Install JupyterHub and JupyterLab from ground up
  2. The Littlest Jupyter Hub

I have also forwarded the port 8000 to ip server in Putty.

For option 1 after following all the steps and when I run command:

sudo systemctl status jupyterhub.service

I get following message in terminal:

Hub API listening on
JupyterHub is now running at8000

According to guide, I should be able to open the site.
But I get “This site can not be reached” error message (Google Chrome)
I tried to open it using:

https //{ip server>/8000
https //

I have also granted all access to port 8000 and 8081 for EC2 instance on AWS.
Any help in the right direction will be really helpful.

The output of sudo systemctl status jupyterhub.service is quite informative - everything is up and running. Maybe you can ask for help in a forum that deals with Putty, SSH tunnels, and firewalls? From your information it looks like a networking issue.


Thanks @1kastner for the quick reply. You may be right - but it’s a rabbit hole and I am scared to go that way.
It says hub is listening on port 8081, and when I ran nmap it doesn’t show 8081 in the list.
So need to investigate that.
Happy new year.

Can you share which processes are listening on which ports?

@1kastner, I was able to install hub using ground up approach, but then it gave trouble while spawning.
I then shifted to tljh and was able to install and run hub.
The problem might have been in my security configuration of EC2 instance. I added some custom IPV and enable echo request. That did the trick for both ground up and tljh approach.
Thanks for asking me the question - it led me investigate it further - but did not take the screenshot to answer back. Sorry.


Great to hear that the issue is solved!

1 Like