Trying to use latest JupyterLab in TLJH gets me a blank page

Hi! I tried using @yuvipanda WIP pull request Upgrade to JupyterLab 3.0 by yuvipanda · Pull Request #647 · jupyterhub/the-littlest-jupyterhub · GitHub to use the latest JupyterLab in TLJH. However, when I run it and I try to enter the lab interface, I get a blank webpage.

The Firefox developer tools show an error: Uncaught (in promise) TypeError: is not a function

And the source is the minified main.722fcaa2f23743df70b8.js, whose first characters are these:

(()=>{var e={37559:(e,t,r)=>{let a=null;function n(e){if(a===null){let e={};if(typeof document!=="undefined"&&document){const t=document.getElementById("jupyter-config-data")

Downgrading to jupyterlab<3 did the trick.

Does this error shoes up on JupyterLab startup?

Have you been able to try with the suggestions listed in the PR?

Hi @jtp , thanks! Yes, I saw your comments and tried those too, except the tornado part that you wrote a few minutes ago. However I’m not in a rush, I can try again when the final list of dependencies is agreed.

Right, but it’s great that you already started testing this PR.

Maybe some troubleshooting commands like pip list, jupyter labextension list or even jupyter troubleshoot can give more info?

Another one worth trying, still in the user environment where JupyterLab is installed, would be:

jupyter lab build --minimize=False

This should normally rebuild JupyterLab without minimizing the source, so hopefully the error message will be clearer.

I tried reproducing the problem on another machine but couldn’t do it. It looks like applying the PR as it stands now, upgrading tornado, and then doing a jupyter lab build --minimize=False as you advised, left the hub in a working state. All good, I guess! :slight_smile: Thanks for the help!


This part is mostly for debugging normally.