Safari can’t open any websites after using Jupyter notebook.

iMac Ventura 13.4, with Safari Ver. 16.5 (18615.

I had downloaded Jupyter notebook. I updated Python, and pip, using Terminal (Much trial and error! An impressive, but intimidating, beast).

Eventually got Jupyter notebook working. It uses ‘localhost’? (my computer as a server? Not sure what this means)

After a couple of days of trying Jupyter notebook, I logged out of all (I think) the Safari tabs, then tried to open other websites.

Safari can’t open any sites. (It worked perfectly before.)

The app opens, but when I click in the search box, my ‘Favourites’ icons show, but are grayed out. (My Reading List icons are also grayed out.)
When I type something in the search box and press enter, the coloured ‘progress line’, under the search box, just moves along a little, then stops/hangs.

Then I get this message:

“ Safari can’t open the page [ . . . ] because Safari can’t establish a secure connection to the server [ . . . ] “

Then a macOS update ( Ventura 13.4 ) became available, which I allowed, thinking it might help the situation.
No change to Safari after the update, but Google Chrome browser works. I haven’t opened Jupyter notebook in Chrome, in case that gets messed up too.

What I’ve tried:

  • I’ve removed all Safari website data (Safari/Privacy/Manage Website Data).

  • Deleted all Safari history.

  • Have done a Safari ’force quit’.

  • There is no ‘Reset Safari’ option.

  • I have the Safari ‘Develop’ tab showing, and have done ‘Empty Caches’ in there.

  • My time settings look ok.

  • All Ethernet Proxies are switched off. One Proxies ‘box’ says “Bypass proxy settings for these hosts and domains: *.local,169.254/16” (No idea what that means).

  • DNS Servers are set to then

  • Under TCP/IP I did ‘Renew DHCP Lease’.

  • I did ’Forget’ my network, then reconnected.

  • The fact that Chrome works suggests my network settings are all ok, right?

  • Booting into Safe Mode doesn’t help; neither does opening Safari using Shift/Option/Command.

  • I don’t have a ‘normal, personal’ router - I’m in a Village, and use what we’re given. I don’t know how to restart the router, so just switched the house mains power off, then on again.

  • I can’t find anything obvious on the Jupyter forum, or Stack Overflow, or Ask Different.

  • I did try several suggestions from ChatGPT.

  • I don’t have any extensions or plugins.

Maybe Safari isn’t broken - maybe it just can’t find its usual server? Does this make sense? If so, how do I achieve this?

All the above hasn’t helped. I don’t need Jupyter to work, anywhere - it’s too complex for me.
Chrome’s still working, and I could live with that, but would prefer Safari to be fixed, if possible.

24 May 2023
SOLVED. I’ve posted the answer on SuperUser

The direct link to the solution on SuperUser is here.

Just as you were warned here cross-posting without linking all the original posts is not allowed. You should link to all if you do cross-posts so that all seeing the questions can look at the other place and see if what they’d add was already covered. Otherwise you waste the time of multiple people volunteering to help you. The more you cross-post without linking, the more of people’s time you waste. You posted this apparently at least three places.
The other reason to link any and all cross-posts right from the outset so that people having the same problem can find the solution easily. If the cross-posts aren’t linked then those following in your footsteps may miss that elsewhere there is a solution. To your credit, you updated your cross-posts later to add a vague mention that there is a solution at SuperUser. Thank you for that. Ideally, you should link to the other post or tell how to find it better than you have. I just finally found your post and added a link at the end of your post below where you vaguely referenced it.

I apologise for not doing the correct thing. I’m a new user, and still learning. Thank you for your help, and your time.

1 Like