R Shiny app on Mybinder: Launch attempt failing

Hello there,
Two months ago I’d set up a functional binder project that launched the R Shiny app successfully using the following link: https://gesis.mybinder.org/v2/gh/NIMH-HBCC/HBCC_snRNAseq_sgACC-DLPFC/main?urlpath=shiny/shinyR_HBCC_FigShare/
The associated Github repo is here: GitHub - NIMH-HBCC/HBCC_snRNAseq_sgACC-DLPFC
Since last two weeks it stopped working with the following message:

And now that I’m trying the above link without “gesis” in front of “.mybinder.org*” the link, it is not working either.
I have captured last few lines of the logs while it was loading:

Pushing image
Pushing image
Pushing image
Successfully pushed 2lmrrh8f.gra7.container-registry.ovh.net/mybinder-builds/r2d-g5b5b759ajeetmandal-2disee-5fposted-5fon-5fjns-9a1b14:974468747a7c544fcd47137d5c5fd1b27bb295e4Built image, launching...
Launching server...
Server requested
2023-04-18T15:02:51.218618Z [Normal] Successfully assigned ovh2/jupyter-ajeetmandal-2disee-5fposted-5fon-5fjns-2d1zmwbgzo to user-202211a-node-a04bcb
2023-04-18T15:02:52Z [Normal] Container image "jupyterhub/mybinder.org-tc-init:2020.12.4-0.dev.git.4289.h140cef52" already present on machine
2023-04-18T15:02:52Z [Normal] Created container tc-init
2023-04-18T15:02:52Z [Normal] Started container tc-init
2023-04-18T15:02:54Z [Normal] Pulling image "2lmrrh8f.gra7.container-registry.ovh.net/mybinder-builds/r2d-g5b5b759ajeetmandal-2disee-5fposted-5fon-5fjns-9a1b14:974468747a7c544fcd47137d5c5fd1b27bb295e4"
Launch attempt 1 failed, retrying...
Spawn failed: pod ovh2/jupyter-ajeetmandal-2disee-5fposted-5fon-5fjns-2d1zmwbgzo did not start in 300 seconds!
Server requested
2023-04-18T15:13:39.751746Z [Normal] Successfully assigned ovh2/jupyter-ajeetmandal-2disee-5fposted-5fon-5fjns-2dole2gwoa to user-202211a-node-a04bcb
2023-04-18T15:13:45Z [Normal] Container image "jupyterhub/mybinder.org-tc-init:2020.12.4-0.dev.git.4289.h140cef52" already present on machine
2023-04-18T15:13:45Z [Normal] Created container tc-init
2023-04-18T15:13:46Z [Normal] Started container tc-init
2023-04-18T15:13:48Z [Normal] Pulling image "2lmrrh8f.gra7.container-registry.ovh.net/mybinder-builds/r2d-g5b5b759ajeetmandal-2disee-5fposted-5fon-5fjns-9a1b14:974468747a7c544fcd47137d5c5fd1b27bb295e4"
Launch attempt 2 failed, retrying...
Server requested
2023-04-18T15:16:24.940716Z [Normal] Successfully assigned ovh2/jupyter-ajeetmandal-2disee-5fposted-5fon-5fjns-2dioeuq3y7 to user-202211a-node-a04bcb
2023-04-18T15:16:25Z [Normal] Container image "jupyterhub/mybinder.org-tc-init:2020.12.4-0.dev.git.4289.h140cef52" already present on machine
2023-04-18T15:16:25Z [Normal] Created container tc-init
2023-04-18T15:16:25Z [Normal] Started container tc-init
2023-04-18T15:16:26Z [Normal] Pulling image "2lmrrh8f.gra7.container-registry.ovh.net/mybinder-builds/r2d-g5b5b759ajeetmandal-2disee-5fposted-5fon-5fjns-9a1b14:974468747a7c544fcd47137d5c5fd1b27bb295e4"

Could you please help me fixing this or suggest how to deal with whatever is going wrong? We’ve this Shiny app associated with our publication and I’m now concerned since it broke.
PS: Apologize, in case I’ve failed to correctly formate the image, links and log texts in the post.

The launch log you included isn’t showing a problem yet, other than you not being patient enough. OVH can take a really long time sometimes when I use it from the United States. I have no idea why. It isn’t consistent in a lot of ways that make it hard to ascribe the issue. It isn’t consistent as some launches from some repos are fine but hitting the same one later in the day sometimes can be slow. (More about OVH below.)

I found changing to Google worked for launching your repo on MyBinder.
However, Shiny still fails to work. (But right not Shiny example isn’t working either [see below].) And I think there is a memory limitation issue so that this won’t work while Gesis is being odd today. I opened RStudio from the session and tried running your app.R code in it and the console seems to crash. (R Session Error: crashed the R session due to unexpected crash and lost the workspace.) I figured it was a memory issue as Google and OVH are much more limited than the offering Gesis provides. I may be wrong though. It was just a guess given what I saw.

Returning to trying from OVH:
So right after a very launch log showing and length and things very similar to what is in your post, I had a successful launch on OVH. It took like at least eight or more minutes to work, but it did. Your app of course still fails to initialize just as it does at Google. But OVH will work for a launch of a session if you keep waiting. I just switch to lab after it launched on OVH and then tried running your app.R code in RStudio again and again it crashed the R session due to unexpected crash and lost the workspace.

More disturbing to me for the prospect of getting your Shiny app working quickly again is that the current Shiny example from the binder-examples/r repo here fails to work. While it launches fine. It has errors on it so that the Shiny dashboard doesn’t work. I don’t see any report of an issue with it yet. Although this may be completely unrelated to the issues above. Maybe it is is just a coincidence I stumbled upon it while trying to compare and contrast Shiny launches.

There’s ongoing work on OVH to improve it’s performance

I just took a quick look at GitHub - binder-examples/r: Using R with Jupyter / RStudio on Binder
It looks like the external datasource requested in r/server.R at e6a2b236269ab7d8767509854420e053f783a9f6 · binder-examples/r · GitHub (http://svc.metrotransit.org/NexTrip/VehicleLocations/0?format=json) leads to a 404, so hopefully it’s just a change in the external data provider rather than a systematic RShiny problem.

1 Like