Question about voila& binder

I am trying to create a binder-voila-repo with the following link (created automatically by the binder-web-interface after I tried to follow voila’s instruction on how to set up a binder to what they call the “binder endpoint”:

the binder/container builds and I am able to access the jupyter notebooks, however, I am getting a 404-page not found for the voila-ified site.

I tried to follow other successful builts closely (e.g. this one:, but it doesn’t work for me.

thanks and best, r

It doesn’t look like you followed step #2 here like it said since your requirements.txt file lacks voila.

Also the URL on your badge didn’t seem to be correct. You need follow the example on the launch binder badge in the voila README.

If you go here and launch you’ll see voila tries to run it, but seems to intermittently have an issue with data fetching. (I found it worked on a try later when I ran it in the Jupyter notebook interface first before switching back to the Voila session URL. I doubt that made much difference honestly.) I added the basics one from the voila example and that one works reliably well when you select it from the list.

1 Like

thank you! (stupid mistake - sorry!) best. ralf.

1 Like

Actually, the URL issue is quite tricky. (As evidence of that, see here and look at all the folks saying link doesn’t work until this follow-up.) I think the documentation may need some clarifying. You may have some insight into how to make it better having just tried? Since Voila is now part of Jupyter, I am sure issues and pull requests would be welcome to improve what you were using.