Problem during push using binderhub

Hello guys
I’ve just installed binderhub on my openshift instance and everything is working properly except the final push . I receive the following error
“Error during build: 500 Server Error: Internal Server Error (“You cannot push a “root” repository. Please rename your repository to docker.io// (ex: docker. io//test-5f-2dogctb16-2deoap-2dd169-5f-2djupyter-5f-2dnb-2drabbit-5f-2dtest-35cd2c)”)”
Can you help me?
Honestly, I don’t understand what I have to modify…thx in advance for your support
PS: below my config.yaml and my secret.yaml
config:
BinderHub:
use_registry: true
# image_prefix: my_docker_hub_id/binder-dev-
image_prefix: my_docker_hub_id/bindertest
##############################################
jupyterhub:
hub:
services:
binder:
apiToken: “4738139b910cad28b9bfcfe63d7f6320dbe57f9f667fd75ba3a2e5b381c891b9”
proxy:
secretToken: “f8d0dd7b952c00c7e83ca005d96eb6d56adpd925c316905df3490bfe9d98978q”
registry:
url: “https://docker.io/my_docker_hub_id/bindertest
username: my_docker_hub_id
password: my_pass
I tried also removing the “URL” as described within the official documentation but the problem persists

Update:
I’ve just created a new k8s cluster on gke and also, in this case, I receive an “invalid credentials” error (obviously the credentials are correct)

Successfully tagged thewoz87/binder-dev-ID…
unauthorized: incorrect username or password

update:
I solved the problem regarding the login, substantially the config.json automatically deployed starting from the secret.yaml was not correct in particular the problem was the base64 string.So I edited the secret binder-push-secret adding the correct base64 string and now I’m able to push my image.