Papermill nbclient conflict


I wanted to include the use of Papermill, which seems brilliant, but i get this:

ERROR: nbclient 0.5.1 has requirement nbformat>=5.0, but you'll have nbformat 4.4.0 which is incompatible.
ERROR: jupyter-client 6.1.11 has requirement jupyter-core>=4.6.0, but you'll have jupyter-core 4.4.0 which is incompatible.

How can I update to meet with these requirements in my BinderHub deploy?

I run
so it is not bleeding edge, but not old either compared to the Papermill versions I have tried.

Hi @MichaelNygaard, Which version of papermill are you trying to run? 2.3.2?

Also are you running on or an on-site deployment of BinderHub?


I have been trying a lot of versions. If you could state a Papermill version compatible with BinderHub release version: version="0.2.0-n465.hb35ec4e, which I am deploying on GCP, then it would be very much appriciated. I have tried anything from bleeding edge down to version 1.2