launches just "hang", are you using an ad-blocker (Ghostery, PrivacyBadger, etc)?

Hello :wave:!

If you use as well as an ad blocker, privacy enhancing browser extension or configured your browser to block trackers we would like to ask you for your help.

We started seeing increased reports of launches “just hanging” with error messages like “Event stream failed to connect” and similar over the last few months. This has been a slow increase and until now the problem was solved by reloading the page. However we recently realised that some people, some times, on some browsers receive this error because they use browser settings or extensions that increase their privacy. Because of the many “some …” it looks like this is a problem with being unstable.

We’d like to fix this.

We don’t track our users but the way works looks very much like how a tracker would look (connecting to “unrelated hosts” and sending stuff there). Right now we think this is why some parts of get flagged as “tracker” and hence blocked.

You can help

You can help by checking if you have a extension or browser settings that block trackers and posting here if you experience problems. This will help us understand when and why which tools block things.

What information do we need?

We will at least need: browser name and version, which extension you use, browser config related to ad blocking, which repository you tried to launch. If you know how to post the content of the JS console and network inspector that would be super useful as well.

We want to be part of a clean web that respects the privacy of users! (On a personal note: I certainly expect the web to work when I block malicious tracker behaviour). So figuring this out is important to us, but it will probably take some time because none of us have ever worked on something like this before :wink: (if you are an expert on trackers, browsers, and the like … please do get in touch)

Thanks for helping us figure this out :smiley: