Missing Export Notebook As

Not sure what happened, but Export Notebook As has diseappeared from the File menu in my jupyter-lab installation. This is a conda installation, and I have done recent updates. I’m not sure how to either troubleshoot or restore the item.


Same for me. This is my base environment and I haven’t updated any jupyter related packages in a while. Don’t remember when this option vanished but I’ve used it in the past.

This is my setup

Python implementation: CPython
Python version : 3.7.9
IPython version : 7.19.0

It’s not quite the same situation, but I wonder if trying the solution at the end of the post here may help?

Earlier in that post is a question of whether going to the classic notebook mode via Help > Launch Classic Notebook and then use Download as from the File menu in classic mode will work for you at all? And if it works, is that sufficient for your needs?

Got the same issue over here with my yunohost installation of jupyterlab. I too used this option before and set it up by installing nbconvert and all the neccessary packets. Out of nowhere the option to “Export Notebook As…” vanished from the File menu. Anyone got a solution for this? Even reinstalling jupyterlab didnt help.

ps. nbconvert still werks, tested it by running a conversion from the terminal. weird stuff…

Funny enough, the solution is just to refresh the page. That works on me. Found the solution from here

1 Like

You can use

pip uninstall nbconvert

and then

pip install nbconvert

It worked for me!

This happened to me due to some pip / home-brew file path conflicts. The following fixed it:

brew install jupyter
brew link --overwrite jupyterlab
1 Like