No PDF export via menu

Hi there

I’m experiencing an issue with JupterHub and JupyterLab where I’m unable to export files to PDF via the File > Download as or File > Export Notebook As... options.

Through the CLI and also within notebooks I can run !jupyter nbconvert --to pdf ... to convert, but not from the menu itself. When selected via the menu, a new tab opens up, but no prompt to download appears like the other options - the page remains blank.

I’ve tried with both nbconvert installed system-wide and within one of the kernels, but this hasn’t resolved the issue. All other export options work without an issue.

I’m currently running this on a CentOS 7 install, and as a result had to install texlive2020 as the version in the CentOS repo is considerably out of date.

Does anyone have any idea as to what I could check to see why this isn’t working as expected?

This is the closest issue I’ve seen to the problem. but I’m not sure if the file configuration is compatible with the file I have.

I’ve entered the below lines, pointing to both the full path to each binary and just the name (not at the same time) as I have the containing directory to the system path, but this doesn’t appear to resolve the issue. Both xelatex and pdflatex have been tried as well.

c.PDFExporter.latex_command=['PATH_TO_LATEX_INSTALL', '{filename}']
c.PDFExporter.bib_command=['PATH_TO_LATEX_INSTALL', '{filename}']


Unfortunately, everything exports now, but I don’t have an answer as to why - sorry if anyone encounters this in the future. If the reason as to why it now works comes up, I’ll update again.