List of supported dependency version for binder

Is there a way to determine the supported version for @lumino and @jupyterlab packages for the online JupyterLab IDE (https://hub.gke.mybinder.org/) ?

The backend of mybinder.org uses repo2docker. The current version of JupyterLab is 2.2.0:
https://github.com/jupyterhub/repo2docker/blob/8fe59166acf964cfc74d313b2c974bce48905225/repo2docker/buildpacks/conda/environment.yml#L4
but you’re free to install a different version in your repository.

The JupyterLab docs on authoring extensions refers to jupyterlab/static/package.json which doesn’t seem to exist in https://github.com/jupyterlab/jupyterlab, so maybe the docs are out of date?

repo2docker will be updated to default to JupyterLab 3 at some point in the future, so it’s worth bearing that in mind.

I got confused because the jupyter.org sends users to JupyterLab 1.0 while all the docs are pointing to 2.0 now.

image

Is there a mybinger.org demo using JupyterLab 2.0? (sorry i"m still noobing in this world).

Any repository should have jupyterlab 2 installed in it unless a different version is explicitly requested. For example https://github.com/binder-examples/conda has JupyterLab 2 without having to do anything special.

@manics do you know why we get a popup saying “jupyter-offlinenotebook has to be included in the build”?

I don’t know what’s causing that. I was in the middle of typing a similar reply to you when I also discovered that. AFAICT it affects all recent repo builds… I’ll investigate further.

That damn arrow of time :-/

I opened https://github.com/jupyterlab/jupyterlab/issues/8986 to fix this.

2 Likes

I’ve created an issue here for the popup dialog:

1 Like

All fixed now thanks!