Image build but not launching


I tried to install Binder on a MicroK8s installation. Everything worked fine, then I gave it an example Git repo with a very simple notebook. It seems so that the image was build (and pushed to the registry), but then it fails to start the image. I got this error in the browser window:

Found build image, launching.
Launching server …
Launch attempt 1 failed, retrying…
Launch attempt 2 failed, retrying…
Launch attempt 3 failed, retrying…
Internal Server Error

I took a look at the logs/description of the pod and found this:

HTTP response headers: HTTPHeaderDict({‘Content-Type’: ‘application/json’, ‘Date’: ‘Fri, 17 Apr 2020 11:43:04 GMT’, ‘Content-Length’: ‘300’})
HTTP response body: {“kind”:“Status”,“apiVersion”:“v1”,“metadata”:{},“status”:“Failure”,“message”:“pods “jupyter-thomz-2dsomenotebooks-2d55aslfq3” is forbidden: no providers available to validate pod request”,“reason”:“Forbidden”,“details”:{“name”:“jupyter-thomz-2dsomenotebooks-2d55aslfq3”,“kind”:“pods”},“code”:403}

And now I’m stuck … I googled around, and maybe it has something to do with permissions / policies / RBAC (which is enabled), but I’m not sure?

Thanks for any help!

There’s an old issue on JupyterHub/Microk8s here:

You might find some ideas on things to try.

Thanks a lot, but in the meantime I gave up on MicroK8s and try an installation from scratch :slight_smile: