Getting "user ... is not allowed" 403 error trying to access a colleagues notebook

I’ve got a Jupyterhub server. I can view notebooks I’ve created just fine. When I try to access a colleague’s notebook I get an error: “403: Forbidden”. “User <my_user_name> is not allowed.”

How can I fix this? Thanks.

1 Like

Hi @slnm, I think you use the default spawner. The default spawner just based on Linux file system (If you use linux).
One solution is that put your users in a same user group and let group users have rwx permission.
Another solution which I don’t recommend but simple is change the default file permission to 777

Hi. Thanks for your engagement. It’s not a linux permission issue. I set my .nb file permission to 777 and I had the user who can’t access my notebook try to cat the file from a linux shell. The cat worked fine.

Other ideas?


Hi @slnm, Do all users share the same directory?
Can your show your settings in ?

So, I found this issue.

It’s a known problem. I tried their workaround of users created a share directory of notebooks they want others to see and symlinking to their share directory and that worked.

Apparently, this is not a bug but part of the design.