ServerError Forbidden for files in JupyterHub cloned from a github repo

Hello there,

I am struggling to get access to the notebooks in a repository.

I have cloning the repository by hand using the terminal in TLJH and also using the link created by nbgitpuller (but thats not the issue) and the repo shows up in the JupyterHub server however the contents don’t seem to be accessible. I have tried to navigate to certain directories and the directory just says:

Server error: Forbidden

This happens when trying to pull the repo in both ways. I have also tried it with a much smaller repo that only contains one notebook and I get the same error.

However, when trying to open a requirements file that is in the base directory (i.e. not a notebook and does actually show up), a new window opens and the file shows as:

Error! Forbidden
Saving disabled
See console for more details

I would appreciate any help with this issue!

Is there a chance you used sudo to clone? What do you get from ls -l and whoami in a (JupyterLab) terminal in the directory?