Error message opening jupyter lab

Jupyterlab only open correctly if i copy the link that are shown in the terminal .
It is similar to this problem : Jupyter Notebook no longer automatically opens in browser · Issue #5361 · jupyter/notebook · GitHub

The error says :
“Access to the file was denied
The file at /home/ricc/.local/share/jupyter/runtime/jpserver-4786-open.html is not readable.
It may have been removed, moved, or file permissions may be preventing access.”

I tried changing the as someone in that topic said but nothing changed. anyone that know how to open it correctly ?

Thanks for posting.

Jupyterlab only open correctly if i copy the link that are shown in the terminal .

How else are you trying to open JupyterLab?

Hi krassowski , as i said the only way to open jupyter lab or jupyter notebook is to copy and paste the links are shown in my terminal after i run ’ jupyter lab ’
i’ve tried changing my default browser app to chrome (i’m using firefox ) and in this case it opens directly without copying and pasting. but iwant firefox to be my default browser
By the way i’m using Ubuntu .

What else have you tried?
What changed on your system?
What were you doing before? Or what do you expect to do normally to open JupyterLab?

That last question was what @krassowski may have been asking with:

A lot of us work on remote machine machines that have more power than a local machine and allow us to do things more reproducibly than the current machine we may have in our hands at the time. So we don’t necessarily know what the local user expects. In other words, putting the link in the browser is generally how we do it. I know others use Anaconda navigator and can kick off Jupyter that way. And so with various routes possible, we aren’t necessarily following what you may be doing and expect to happen?

Have you worked through the discussion about having the browser open Jupyter here?

I tried to mess around with some suggestions on the internet but didn’t work anything(also chaging the default browser of jupyter lab via terminal), i changed so many things that i had to reinstall jupyter lab ( just in case) . The only thing that “worked” was changing in the settings of my Ubuntu system , the default browser to chrome.

1 Like