Could not resolve ref.. is your repo public? ERROR

Hello, I keep getting the error “Could not resolve ref for gl:SophieBenaroya%2Fapp-ol-opx-spl-sbf.git/HEAD. Double check your URL. Is your repo public?”, even though the repository is public… I have tried adding a requirements.txt file and uploading files differently, but I keep getting the same error. Can anyone help me out fixing this?

I put everything in the main branch, and specified this on the binder input page, but I still cannot get it to work.

What are you filling in on the form at It can be tricky.

This URL builds and launches an app it seems, using your ‘main’ branch:

(It notes something is missing, specifically, Directory not found: "" when you are inside the session, but otherwise launches a session.)

Note the pattern in the URL. Usually it is advisable to take another example that works and try to reverse engineer if you are having trouble making a URL.

To make the one I posted above using the form, what I did was take the main part of your repo URL, change the repo site to GitLab from the drop-down, and then add main in the form entry for branch.

Attempting to reverse engineer your problem from what you initially posted:

It would seem you didn’t indicate the 'main' main branch correctly in the form and let it default to ‘HEAD’, I gather.


1 Like