Cannot edit the default shortcut on JupyterLab on Sagemaker

I want to use tmux on JupyterLab on AWS Sagemaker. To use tmux, I need to use the shortcut ctrl + b to do something with it. But, the shortcut is same with the shortcut from JupyterLab. I have tried to change and remove the shortcut, but it seems that I cannot delete the default shortcut there. Anyone please help if you have the solution.

Okay I found the solution from here. Deletion/override of system default keyboard-shortcuts · Issue #6249 · jupyterlab/jupyterlab · GitHub

Firstly, JupyterLab on AWS Sagemaker is quite confusing as I can’t find the JSON Editor File to edit the Keyboard shortcut at first. But after I found it, I just paste the following line into the “shortcut” value like below:

    "shortcuts": [
          "command": "application:toggle-left-area",
         "keys": [
              "Accel B"
         "selector": "body",
         "disabled": true

And boom you can use tmux happily.

1 Like