Bokeh server with Binder link shows blank page

I am trying to create a shareable Bokeh dashboard with the help of a Binder link but whenever I create a URL, binder opens a blank page. I tried the solutions from this similar topic but the blank page stays blank. I tried running my script (see repo locally and it takes a while to load but eventually executes as it is supposed to. With the small amount of information available I am all out of luck. Please let me know if you need or know something.

My binder link looks like this: https://hub.gke.mybinder.org/user/cayah99-bokeh-6sv1edrv/proxy/5006/bokeh-app?token=RCYMEHEDT66s_WraS8YK4Q, I was not allowed to post more than 2 links in my main post so ill do it this way

I actually wrote a post about it, which you can find here. I would follow it step by step and if it still doesn’t work, I would do some debugging (as explained there). Hope it helps

2 Likes

I actually found your page today, so I tried the debugging part with creating a new environment with the env file in my github, but when running my main.py locally in the new environment it worked perfectly… Do you have any more suggestions about ways of debugging? I find’t really get your point in running the script in the 'top level’of my repo as I am not that experienced with Github, but as stated before I tried to do the debugging locally with the environment specified in my repo and it didn’t result in any errors…

Hi Kars,
That link you posted is the temporary one for you. It will be gone a few minutes after it is made and so that is not something you want to post for people looking to test things. It is a very common mistake when learning about Binder.
For a normal launch, the binder service offers the link you want to share that would launch an instance for each new user. But that just will go to the Jupyter notebook interface and you want to go to your Bokeh app and so you need to do some hand editing to get the proper link like covered at step # 4 at https://arturomoncadatorres.com/creating-a-shareable-bokeh-dashboard-with-binder/ or like you see when you hover over the launch badge at https://github.com/binder-examples/bokeh .

So for yours, it would be the following to share in a post (or make into a launch badge) and not a specific instance:

https://mybinder.org/v2/gh/Cayah99/bokeh/master?urlpath=/proxy/5006/bokeh-app
1 Like

Yes this is absolutely correct, I noticed it earlier but it seems that I forgot to edit my topic. But also for the shareable binder link https://mybinder.org/v2/gh/Cayah99/bokeh/master?urlpath=/proxy/5006/bokeh-app, I still get a blank page… I have been trying to solve and change things for almost 3 days now. I tried to run the main.py script from the weather example which ran absolutely fine which makes me think that there is something faulty in my script, but I have tried to replicate my repo locally and it works fine without errors… Do you have any more ideas/suggestions that I could try?

I don’t know if you changed something, but I just accessed your binder link and your dashboard launched with no problem.

Although the image was already built, it took a few seconds to launch from Binder (which is normal). After that, there was a blank page for <5 s and then it loaded.