Notebook added to binder but it doesn't run (kernel not connected)

I have added my first notebook into mybinder.org, and it displays OK but doesn’t seem to run. The kernel status shows as “Not Connected” and clicking that button doesn’t connect it. I can’t work out how to see what the error is so I’m at a loss as to how to rectify this. Can someone please point me to the section of the docs that explain what I need to do to get things into proper order? BTW the notebook is here. Thanks in advance for your help!

Hi James :wave: !

thanks for finding us on gitter and then posting here instead :slight_smile:

The hub.mybinder.org link you posted is to your personal instance in the cloud, so no one else will be able to access it. The link to share looks like: https://mybinder.org/v2/gh/monocongo/climate_indices/master which you get when you enter you repositories link into the front page of mybinder.org (Trying to solve the UX problem of “which link should I post??!?” is on our list but it is a bit tricky and also “just takes time” :slight_smile: )

Anyway, looking at your repo at https://github.com/monocongo/climate_indices you have a setup.py so we should have installed the dependencies listed in it. So that is all good.

I think the most likely explanation for what you are seeing is that you started the cloud instance (by visiting a link like this) but then did something else while the spinner was spinning. By the time you came back we had already garbage collected the idle instance. We do that fairly aggressively (~10min of inactivity). So I’d try visiting https://mybinder.org/v2/gh/monocongo/climate_indices/master again and see what happens. When I just tried it a new notebook opened and I ran some simple Python in it.

Thanks, Tim. You’ve cleared things up a bit more for me, very helpful. :grinning:

It looks like my setup.py needs some love, because when I run the first cell of the notebook file I’m focusing on at first it’s missing the bokeh module, so I probably need to add that into the install_requires section.

Thanks again for your help getting me over this initial usage hurdle.

1 Like

Here’s an “all you can install” buffet, sort-of… :slight_smile:

1 Like