Module Not Found Error -when running the ipynb notebook- via BINDER session

Hello Binder forum:

I am using Windows 10 and using anaconda environment. 1.9.12.
I am trying to create a binder from the following GitHub repo,

From the anaconda navigator, Jupyter Lab, running the notebook(s) is successful. I have extracted the environment dependencies using the following command,
conda env export > environment.yaml

It looks like BINDER (via for some reason is using the old image
(log: Found image; launching image…). Not sure how to force BINDER to recreate the image.
After the BINDER session is ready, when I tried to run the notebook, I get

ModuleNotFoundError Traceback (most recent call last)
7 import time
8 import argparse
----> 9 import numpy as np
10 import pandas as pd
11 from import json_normalize

ModuleNotFoundError: No module named ‘numpy’

Any help would be greatly appreciated.


Hi Ravi, you can trigger Binder to rebuild the image by pushing another commit to the repo. This code be something small like a documentation change. Or if you’d like quicker builds for testing, you can use repo2docker locally

Thanks very @sgibson91 for the quick response. I tried your first option. I moved the code and modified the markdown portion of the Jupyter notebook. It doesnt work. I added the environment.yml, hoping that BINDER will rebuild, it also didnt work. I havent tried your repo2docker option. I will let you know. Thanks very much for your time.


There is also this advice on creating environment.yaml files as yours looks quite complex