Binder launch fails with OSError: [Errno 28] No space left on device:

Hi; we are seeing a binder error when launching notebooks:

OSError: [Errno 28] No space left on device: ‘/tmp/pip-ephem-wheel-cache-dp8minvs’

Is this something on our side, or is there something we can do to solve the problem?

Is this the same as seen before in "No space left on device" error

Thanks a lot!

Best, Kati

It most likely is the same. And it doesn’t mean anything more than try again later. However, you need to share your repo information for others to test & report their experiences.

Thanks, indeed, that was the case.

Best, Kati

Hi there,

I have the same problem with my repo here:

Is there anything I can do besides waiting?



I get the same error with this repo:

Yes, you can use the pattern of the links I offer to others to specify specific locations in the federation to avoid the apparent bad situation. In the case of the OP in this thread, the repo was not shared, and so there were limited alternatives to test and offer.
Yours builds and launches well here.

I get the same error with this repo: Binder

It depends on the hub though:

  • turing: fails
  • ovh: fails
  • gke: fails
  • gesis: OK

Try here @renefritze . And then when your session starts and says 404 : Not Found You are requesting a page that does not exist!, change the end of the URL from /lab to /tree and then hit enter in your address bar. That should take you to the classic Jupyter notebook dashboard.

You have an overly complex requirements.txt for ease in use with MyBinder. I recall from dealing with other’s repos where they just dump the entire freeze list, that it can conflict with proper JupyterLab installation as the MyBinder underlying settings get updated. You apparently have such a conflict and so that is why when it launches and tries to go by default to the link ending in /lab, it fails. (Actually here it was nbinteract, which you don’t have. And so I’d need to play around with eliminating different ones to actually tell which one or ones in your case. I don’t wish to do this now.)
If there is a specific reason for documenting all the versions in a file named requirements.txt, then you should use a sub-directory called binder and place a separate requirements.txt there. (MyBinder will preferentially use configuration files in a subdirectory called binder or .binder.) In the requirements.txt list there in the binder directory, only list the few special packages that MyBinder doesn’t come with by default that your code needs to run without error. And don’t pin any of those, unless you find you must. For example, it looks like you have scipy listed and that would be one to include in the streamlined requirements.txt. Most of your current list, you wouldn’t want there, such underlying things like terminado,nbconvert, nbformat, and tornado that MyBinder handles for you.
Not pinning and only listing the special packages you need in the requirements.txt, will help keep your repo cooperating with the MyBinder machinery longer and because you usually get the current versions of packages developed in step with other packages you use, it actually ends up making your code work longer.

Alternatively, I’ve seen others suggest you rename your current requirements.txt to something like requirements-dev. And then make the new one MyBInder will use as requirements.txt in the root.

1 Like

Great - I did not understand that we can point directly to one of the servers. Thanks a lot!

Ideally, it doesn’t happen as it interferes with the traffic management system in the federation. And so that is why it is only offered as a temporary workaround.

Workaround helps, thanks!

Same problem here: GitHub - khider/ODP846-SpectralAnalysis: This repository contains a Notebook for spectral analysis of the ODP846 record

How do I point to a different server?

This URL compared to what you are using now should guide you. I verified it builds and launches from there.
Let me know if you prefer / need the classic notebook instead.

Thank you! That was very helpful!

Same problem here:

@fomightez I’m seeing this error with all my notebooks posted on Turing.

Is there way to generate links and badges to go to one of the functioning hubs (not

Sorry for the disruption. A new feature intended to improve the reclamation of disk space was deployed to, but it didn’t clear up as much space as it should have! This is hopefully fixed now, but if you’re still having disk space problems please post a link to your repo and the backend server if known.

1 Like