While using jupyterLite my notebook does not respond

I have created a notebook for my students to learn to program python. It starts with 1+2. That simple, but when I press run, nothing happens anymore. There comes an * before the command line but that is all. I worked a month ago. It works on my desktop jupyter notebook. It seems as if the kernel is not functioning. Please help. My class is next week…

Are you waiting for the kernel to show ready before trying to run code?
Have you tried other browsers? Incognito mode?
Do other JuputerLite sites work?

Sorry, I don’t know how to see if the kernel is ready. I never had this problems before so I didn’t look into that. I use google as browser.
Their own demo notebooks does not work either. Just the [*] and nothing happens.

I started in Edge and everything works. So google does not and Edge does.
Thanks for you suggestions.

Just like in a typical, full Python kernel-backed JupyterLab instance the indicator for the kernel is in the upper right side. Always let that clear before trying to run code in JupyterLite. The initial start-up time can be a bit longer than expected and sometimes if you execute code too soon the browser where things are running in can glitch and because of caching and how WASM works behind-the-scenes it seems sometimes it will get stuck. Refreshing the page fully, and other tricks such as using a different browser or incognito mode can help jump-start things.

Since you said you are using it for teaching, I’ll point out JupyterLite is still considered very experimental, see cautions under ‘Status’ on the main JupyterLite page and on the Try Jupyter page where it clearly highlights Experimental. I’d recommend using a typical, full Python kernel-backed Jupyter for a better experience and more abilities for your trainees. Or at least point this out to them. Traditionally, I’d recommend using anonymous, temporary sessions served via MyBinder such as you’d get by pressing the very first launch binder badge listed here on the Sample MyBinder Repositories page (direct launch link here; however, the largest contributor of computational resources exited the federation a few months ago and the experience can be rocky at times. Use of the MyBinder service combined with a online repository like GitHub does though allow you to customize notebooks to launch and have packages pre-installed just like you are probably doing with JupyterLite now.

1 Like


Thanks for you information. The problem is that the students come from different schools with different policies about computers. Some have no rights to install software, some work with mac and others with chromebooks. Therefor I decided to use the online version of jupyter. Than everybody experiences the same things.

Are you familiar with CoCalc?

Thanks again for your help.


Yes, that is best for the issues you stated. However, there are online versions of Jupyter that can be offered that are not JupyterLite. JupyterLite is a fine choice; I’m just advising stressing to your students the current limitations and offer up some alternatives to those that will quickly encounter those limitations trying to apply things they already know or find elsewhere.

I’m only vaguely familiar with CoCalc. I believe it requires sign-up. PythhonAnywhere does as well and offers Jupyter use, too. There’s Anaconda Cloud, too. Alternatively, there is The Littlest JupyterHub for more of a DIY set-up.