No Output Displaying in Jupyter for

I’m taking a Coursera course by IBM and the labs are in Jupyter. I run the code, but I never see any output from the code. I’m running the code with shift-enter, and I’ve also tried from the Run menu. In the screenshot, I run all the code up to and including the cell that ends with, but I don’t see the scatterplot displayed anywhere.

I’m new to Jupyter but I have searched Google for answers to this and found nothing. Can someone help?

There’s still asterisk in the indicator brackets for each of those cells, meaning that they didn’t complete running. Nothing is going to show up until that concludes.

Is there any chance you can switch kernels? The pyolite kernel/Jupyterlite is experimental and can sometimes get stuck in a glitch. If stuck with pyolite: It is important when starting the notebook with a pyolite kernel to give it time to completely run the startup process and go to ‘not busy’ indicator in the activity indicator in the upper right side before initiating running any of your code.
If you’ve already tried restarting the kernel patiently and then run the code again …
Sometimes duplicating the notebook and starting that copy patiently can effectively result in bypassing glitches such as these. Or try it in an incognito window in your browser. Or try it a different browser.

Keep in mind, this isn’t you causing this issue. Hopefully, you’ve had good experiences other times with Jupyter and will have more soon.

Thank you for the help. When I switched to using Firefox everything worked fine. I guess there’s a problem with Edge, but I can use Firefox instead.

If it worked at any point in that browser, it’s probably not the browser specifically. I suspect if you go back in maybe a day or a few days to the original browser, it may work again.