No colour output in code mode. nothing returned

I started a new notebook in JupyterLb in Chrome and the code was black and nothing was returned. I tried restarting the kernel. What worked was using another browser (Brave).

But now I’m on another computer and I have this issue in both browser.

Any ideas?


You’ll probably want to add more details to your post. “I started a new notebook in JupyterLb in Chrome”, doesn’t really provide a lot of specifics. There’s a lot of ways to install and use JupyterLab or not install JupyterLab locally and yet still use it. For example, for the latter, you can use it your browser either via remote cloud computing or inside your browser system using JupyterLite/Web Assembly. Some of this could also be addressed by not cropping the screenshot to eliminate a lot of information, such as the kernel being used. We generally discourage screenshots; however, if you are going to use them then keep them informative.

Plus if it is a local installation, what type of system? Was it working before?

If you happen to be using JupyterLite…

My guess would be you are using JupyterLite and not noticing it is marked as experimental in several places, such as here and ‘Status’ here and then encountering one of the ‘pointy bits’ it has at this time. Simply switching to a different browser works because you are probably in essence starting a new session; the particular browser probably isn’t making much difference in this case. You could probably launch in incognito mode in Chrome and see it work, too, if you are patient and let it completely load and the kernel pass into not being busy (indicator on the far rightside) before attempting to run any code. See here for more about other sharp edges it has.
I’d suggest using a typical, full Python kernel would be easier for you, see here.