What does "is not compatible with the current JupyterLab" actually mean?

When I execute jupyter labextension list, I see the error/warning shown below. However, everything works great. It even works on an earlier version of JupyterLab.

Anyhow, what does it actually mean i.e., what are the consequences of ignoring the warning? :slight_smile:

I’m guessing that the version that my package needs, which is 4.0.0-alpha.15, is being provided by the python package that I installed.

[~/workspace/educational-technology-collective/etc_jupyterlab_authoring] (etc_jupyterlab_authoring)
$ jupyter labextension list
JupyterLab v3.2.1
        @jupyter-widgets/jupyterlab-manager v3.0.1 enabled OK (python, jupyterlab_widgets)

        @educational-technology-collective/etc_jupyterlab_authoring v0.1.6 enabled  X

"@educational-technology-collective/etc_jupyterlab_authoring@0.1.6" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab                Extension      Package
>=3.2.1 <3.3.0            4.0.0-alpha.15 @jupyterlab/ui-components