Unable to open Jupyter Notebook

Hello, I am trying to work with Jupyter Notebook. I have python 3.12 and Jupyter downloaded. I have tried using anaconda and the terminal to start up Jupyter Notebook and both give me a html page saying Error File Not Found. What should I do, I have reinstalled jupyter countless times already. Please help.

Okay. However, the next statement you make, which is “I have tried using anaconda”, is at odds with that. Did you mean you installed via the Anaconda Distribution and used the Anaconda Navigator to try and start Jupyter? If so, then you shouldn’t have downloaded Python and Jupyter yourself. If you haven’t tried installing the Anaconda Distribution yet, then I encourage you to do so. Especially since you don’t seem adverse to using Anaconda, since you mention it. (I didn’t think the Anaconda Distribution was up to Python 3.12 yet as it is relatively new and the Anaconda Distribution is conservative about what is in the base environment. Along this vein, using the Distribution will ensure you have compatible set of software).

If you don’t want to go that route, then maybe try JupyterLab Desktop? See here about it and if you do go that way make sure you read that carefully to understand how you are expected to use it to manage projects as it is different.

Today, I updated my Conda. After updating, I am facing the same issue:

(base) md@MDs-MacBook-Pro ~ % python --version
Python 3.12.4

When I try to open Jupyter Notebook, the web browser displays an empty page at http://localhost:8888/tree. I tried several ways to resolve this issue, including pasting the URL with the token from the terminal (e.g., http://localhost:8888/tree?token=2fa38b7d268b965dc5441192ba30cea3e92b51f56b72810c), but it didn’t work.

Here are the steps I have taken so far:
I ran conda update --all, but it didn’t work.
I uninstalled and reinstalled Conda following the instructions here: Uninstalling Anaconda Distribution — Anaconda documentation. I also ran conda clean --all, but it didn’t work.
I tried upgrading nbconvert and mistune using the following command:

pip install --upgrade ‘nbconvert>=7’ ‘mistune>=2’

but it didn’t solve the issue.

However, JupyterLab is working properly.

Can you please help me resolve this issue with Jupyter Notebook?
version of my conda afterinstallation showed as below
(base)md@MDs-MacBook-Pro ~ % conda --version
conda 24.5.0