Unable to make jupyter-server-proxy working - help really welcome!

Hi,
I am trying to make jupyter-server-proxy working. Don’t know how to debug it.
I am inside a docker container
My installation for jupyer-server-proxy is:
pip install jupyter-server-proxy
jupyter serverextension enable --sys-prefix jupyter_server_proxy
jupyter labextension install @jupyterlab/server-proxy

my configuration file is:
c.JupyterHub.authenticator_class = ‘nativeauthenticator.NativeAuthenticator’
c.Authenticator.admin_users = {‘jhub’}
c.NativeAuthenticator.admin_users = {‘jhub’}
c.serverProxy.servers={
‘test-server’: {
‘command’: [‘python3’, ‘-m’, ‘http.server’, ‘{port}’],
‘absolute_url’: False
}
}

I am launching jupyterhub as root:
sudo jupyterhub -f /etc/jupyterhub/jupyterhub_config.py --port 9090

I can registred my user admin, go the notebook page, but I can not see the Entry under the new menu in the notebook’s default tree view. I tried with jupyter lab, same result.
I can’t see any error printed on screen.

Is it an issue? How can I debug it?

Any help is really welcome as I am working on it for days!

Christian

There are two separate applications

  • JupyterHub manages authentication and starting/stopping singleuser servers
  • JupyterLab or Jupyter notebook which is what you see after you’ve logged in to JupyterHub.

The applications are configured separately, jupyter-server-proxy is on the user-side of things whereas the config you’ve shown looks like it’s for JupyterHub.

Haaa ok I understand. Many thanks for that, I’ll make a test

works fine, many thanks