Unable to launch Jupyter on Binder

Hi - I’m not sure if this is the right place to raise this issue but I have a Jupyter notebook that has faithfully (as of early March) opened.

With no changes to the .ipynb or environment.yml I am now seeing only ‘Invalid build token’ errors when I try to open it:

Any suggestions for code or environment updates are welcome.


1 Like

Hi, I am in the same situation =(, please help !!!

We’ve just added a new backend to mybinder.org to increase the capacity, something may have gone wrong…

Could you share your repo that causing problems?

1 Like

thanks, manics - GitHub - xbrlus/xule at jupyter

The repo of the first one is at https://github.com/xbrlus/xule/ .
It seems to be the main mybinder.org resolver page.
It launches fine using Google or OVH directly.

SearchIT.ipynb (the .ipynb file)

Binder (this is the link, but now not works. When open it with mybinder.org, it works)

Thanks, that’s a convenient work around that you point out for while the issue is worked on.

Work Around for now

For those with this issue now, if you go to mybinder.org and enter your repo in the form and then press the ‘launch’ button, it will launch a session.

Thanks, @Junior19 and @fomightez

I experienced the same “Invalid build token” issue when opening binder in the ipywidgets and ipyleaflet repo, and created these two issues

  1. Binder link is broken · Issue #3765 · jupyter-widgets/ipywidgets · GitHub
  2. Binder link broken · Issue #1111 · jupyter-widgets/ipyleaflet · GitHub

We’re pausing gesis in the federation for now while we figure it out. Thanks for reporting!


I believe we’ve resolved the issue, and are readmitting GESIS to the federation. Please let us know if you encounter any further issues!


@minrk - I’m grateful for the attention this issue received and appreciate the prompt fix

1 Like


I am having an issue with launching a Jupyter notebook from my GitHub repository (GitHub - mettalrose/DS2F_Workshop_Text_Mining: These are materials for a workshop that I am conducting on text mining as part of the University of Arizona Libraries DS2F program.) on mybinder.org. The server is taking a long time to build and the notebook is not launching.

The size of the repository is 1.4 MB and the dependencies listed in the requirements.txt file are nltk, numpy, and matplotlib. I have tried launching the notebook multiple times but the issue persists.

Can someone please help me understand what might be causing this issue and how I can resolve it?

Thank you!

It built in a very reasonable time and launched by going here and entering your repo https://github.com/mettalrose/DS2F_Workshop_Text_Mining in the top line of the form and clicking on the launch button.

I’m guessing that this post about Google no longer being in the federation might have something to do with why it was rocky for you.

@fomightez thanks so much! Building it on GESIS notebooks is working great. However, while building it from scratch is working fine, when I try to use the shareable link to the build with other people, it does not built and leads to infinite delay. Any thoughts on how to share the GESIS build with others? Thank you in advance for your time!

Hi @mettalrose,

I tested the shared link (Binder) and the log shows

Found built image, launching...
Launching server...
Server requested
2023-05-02T07:29:46.963110Z [Normal] Successfully assigned ovh2/jupyter-mettalrose-2dds2f-2dhop-5ftext-5fmining-2drws3277z to user-202211a-node-3126ee
2023-05-02T07:29:47Z [Normal] Container image "jupyterhub/mybinder.org-tc-init:2020.12.4-0.dev.git.4289.h140cef52" already present on machine
2023-05-02T07:29:47Z [Normal] Created container tc-init
2023-05-02T07:29:47Z [Normal] Started container tc-init
2023-05-02T07:29:49Z [Normal] Pulling image "2lmrrh8f.gra7.container-registry.ovh.net/mybinder-builds/r2d-g5b5b759mettalrose-2dds2f-5fworkshop-5ftext-5fmining-7e21d3:08c9b03e0c6c3fdc65c611af590c446390196357"
Spawn failed: pod ovh2/jupyter-mettalrose-2dds2f-2dhop-5ftext-5fmining-2drws3277z did not start in 300 seconds!
Launch attempt 1 failed, retrying...

It’s not building the container. Only pulling from the registery.

Do you know how big is this image? Is it possible to reduce the size of the image based on How to reduce mybinder.org repository startup time ?

UPTATED: The spawn is failing.

1 Like

@rgaiacs It’s not necessarily the size. In the United States OVH fails to work well quite often. See an example of a super small one in a post here. A user in Arizona sees the same thing I see in the Northeast trying to launch sessions using that repo. I don’t know what the issue is. I don’t know if it is something in the browser or what. I use Chrome and sometimes launches from OVH are almost instantaneous. More often though starting sessions via OVH do what is reported above or here or in several other places on this forum.