ToC not loaded in Jupyter 3.1.x (x>5)

Hi everyone,

since version 3.1.5 I am experiencing a very odd behavior of Jupyter Lab:
the ToC of my notebook is not loaded, as the following screenshot shows:

immagine

The funny thing is that if I switch to another notebook within the same workspace, then the ToC of that notebook will appear; switching back to the first notebook does not load the proper ToC though; actually, the ToC keeps showing the contents of the other notebook.
I have tried to reload the page, yet nothing.

As for the technical details, I am working in a conda environment and I have tried to run Jupyter Lab on both Firefox and Chrome, and the currently installed extensions are:

  • dask-labextension v5.1.0
  • jupyterlab-plotly v5.2.2
  • jupyter-widgets/jupyterlab-manager v3.0.0
  • jupyterlab/server-proxy v3.1.0
  • pyviz/jupyterlab_pyviz v2.1.0

I have also tried to build Jupyterlab as minimized and not minimized, same result.
Besides, it is worth mentioning that the last working version is 3.1.4: in this case, under the very same conditions as above, the ToC is loaded without any problem.

Finally, I report that the ToC is completely disappeared (no icon) from my side bar after the last relaunch from Chrome (v 3.1.8)

Any idea of what is happening?
Thanks in advances for any comment.

Best,
anddm

Could you please fill in a bug report on JupyterLab GitHub, most crucially filling in the Troubleshoot Output and the Browser Output section (there ought to be some errors there!) and providing a reproducible example (with a redacted notebook that is affected), please?