TLJH does not work after use a domain name nor enabling HTTPS

Hi everyone!

I’m trying to use TLJH on Compute engine VM from Google Cloud, everything is fine with (https://tljh.jupyter.org/en/latest/install/google.html) but, when I try to add HTTPS to my server, as said here (https://tljh.jupyter.org/en/latest/howto/admin/https.html), it get into a ERR_TOO_MANY_REDIRECTS error.
These are the steps I follow:

  1. Create VM as said in the tutorial.
  2. Wait until TLJH finishes the instalation.
  3. Access to the efimeral IP Google Cloud provide to my VM by copying it and pasting it in the browser, here everything is fine.
  4. Change the efimeral IP to a Static IP provided by Google Cloud.
  5. Access to the static IP attached to my VM, everything is fine.
  6. Access to the server through a nbgitpuller link with the static IP, everything is fine.
    7.1 Access to the server through a nbgitpuller link with my subdomain name, does not redirect to the notebook, just redirect to the login page again but does not validate credentials, so if i try to get it again, just shows the login page.
    7.2 Enable HTTPS using (https://tljh.jupyter.org/en/latest/howto/admin/https.html) with my subdomain name and redirect to syncronizing with github window and then just loops with ERR_TOO_MANY_REDIRECTS error.

What is weird?
Some days ago I had a server running with this, also in Google Cloud, but suddenly it stopped worked, so i’m using a server with Ubutu 18.04.2 that i use for recovery porpuses, but i’ve tried with Ubuntu 20.04 LTS, Ubuntu 22.04 LTS and Ubuntu 23.10 but i can’t make them work with HTTPS enabled.

Any advice? Maybe is the new TLJH version? Or the way i get the SSL certificate is not working nowadays?