The kernel for <notebook>.ipynb appears to have died. It will restart automatically

Hello – I was asked to post this question here as it was not considered a genuine ‘bug’. I suspect that means I am having this issue because I am very new to JupyterHub. I’ve spent about 5 hours trying to solve this to no avail so I would really appreciate any help. Thank you for your time.

Also just to quickly address another solution for this error, my EC2 instance has plenty of memory and storage. I monitor it with top and the memory is only at 13% full when I attempt to use the R kernel in jupyter and there is about 35G of storage space on the instance free.

Bug description

I am running JupyterHub on an AWS EC2 with Ubuntu 18.04. I have followed the steps outlined in the docs before the NGINX part to set up JupyterHub with Conda. Then, I added a few extra steps to set up R. The exact process I went through is documented here.
When I log in using any account and attempt to use R in a notebook, the command hangs and I get this error:

The kernel for Untitled3.ipynb appears to have died. It will restart automatically.

Attempting to use R in the jupyter terminal, any command just hangs for a few seconds and then the whole R session restarts without any message.

Edit: I should add that R works as expected from the ssh command line.

Expected behaviour

R should be working correctly in the notebook and in the terminal.

Actual behaviour

The R session hangs in both cases.

How to reproduce

Follow the instructions I linked to above (I can’t post another link due to being new here).

Your personal set up

  • OS: Ubuntu 18.04
  • Version:
jupyterhub    :1.1.0
jupyter core     : 4.6.3
jupyter-notebook : 6.0.3
qtconsole        : not installed
ipython          : 7.15.0
ipykernel        : 5.3.0
jupyter client   : 6.1.3
jupyter lab      : 2.1.4
nbconvert        : 5.6.1
ipywidgets       : 7.5.1
nbformat         : 5.0.7
traitlets        : 4.3.3
  • Configuration:
    The only non-standard config options are:
c.Spawner.default_url = '/lab'
c.JupyterHub.ip = ''
c.JupyterHub.port = 80
c.PAMAuthenticator.open_sessions = False
c.Authenticator.admin_users = {'jupyter-admin'}
1 Like