JupyterHub & IRkernel misbehaving -- next steps for debugging?

I am trying to get an R kernel working in Jupyterhub β€” it was working on an Ubuntu 16.04 install but it stopped when I upgraded to 20.04 and did a fresh install of everything (default proxy and processor setups; no docker complexities; installed through pip). I followed the instructions from IRkernel for installation, including the dependencies in R and to register the kernel with IRkernel::installspec(). I see the kernel then from JupyterLab but when I try to execute some test (test = 3), I just see an asterisk until it says the server has stopped responding. In the logs I see a bunch of messages like the following (with --debug passed to JupyterHub).

Nudge: attempt 70 on kernel 2cfaed33-b05f-4b08-a5d9-80bbc260c431

I can see from ps aux that a kernel was indeed launched
/usr/lib/R/bin/exec/R -e IRkernel::main() --args /home/stephan/.local/share/jupyter/runtime/kernel- 2cfaed33-b05f-4b08-a5d9-80bbc260c431.json

Python kernels are fine. R is fine, and can load IRkerrnel. I an even get a perfectly functional R console with jupyter console --kernel=ir. If I run the above R script from ps aux without --slave, I get an error saying R_zmq_bind errno: 98 strerror: Address already in us, so I think the kernel is registering. But now I am at a loss to flush out further error messages – also it is unclear to me whether this is an IRkernel problem or a JupyterHub problem, and hence what community I should ask in. Any ideas? I’m afraid it’s rather urgent as I have a lot of R notebooks I need to access in my academic job.

Please try upgrading jupyter-server - the issue you describe was fixed yesterday in v1.13.1 (see timeout on starting kernels of R and Julia Β· Issue #633 Β· jupyter-server/jupyter_server Β· GitHub). Please let us know if it helped :slight_smile:


Oh fantastic, I was convinced I was in an obscure horrible mess and no one would ever respond! This worked immediately.

1 Like