Numba module cannot be imported properly

So this is the message I always got regardless of the kernel I use the environment I am using and python version that is used. I am working with pandapower and I want to use this code.

import pandapower as pp
import numba
 net = pp.create_empty_network() 
 b1 = pp.create_bus(net, vn_kv=20.)
 b2 = pp.create_bus(net, vn_kv=20.)
 pp.create_line(net, from_bus=b1, to_bus=b2, length_km=2.5, std_type="NAYY 4x50 SE")   
 pp.create_ext_grid(net, bus=b1)
 pp.create_load(net, bus=b2, p_mw=1.)

This works okay, but when I run this line:


numba cannot be imported and numba functions are disabled.
Probably the execution is slow.
Please install numba to gain a massive speedup.
(or if you prefer slow execution, set the flag numba=False to avoid this warning!)

I already tried installing and reinstalling numba and combining it with other python versions and environments. I rolled back to python 3.8 because pandapower is tested for versions up to 3.9. So can someone please explain where is the problem. I know I can just ignore it by setting numba=False, but soon I will be creating more complex networks so it would be really helpful if I could actually use numba.

Thank you in advance and kind regards,


I ran into the same issue. Downgrading numba to version 0.56.4 solves the problem at the moment.
See the GitHub issue here: [bug] Incompatibility with numba 0.57.0 version information · Issue #2041 · e2nIEE/pandapower · GitHub