Jupyterlab Extension Building Tutorial Issue

Hi Everyone,

I am working my way through the tutorial on building an extension

When I get to the section: “See the initial extension in action”
It fails.

The instructions for once the extension is installed are to:

  1. Activate the conda environment in a new shell
  2. Launch jupyterlab
  3. Open the Javascript console in the same browser window as jupyterlab.
  4. Refresh the page

According to the tutorial this is supposed to result in the message “JupyterLab extension jupyterlab_apod is activated!” and the extension should appear in the Jupyterlab environment

This does not happen

If anyone else faces this problem with the same tutorial I suggest your try the examples on github: GitHub - jupyterlab/extension-examples: JupyterLab Extensions by Examples

The hello world here worked for me.

It would be great to hear what errors you saw, say in the javascript console. Also, remember you can always look at the “answers” for the tutorial at https://github.com/jupyterlab/jupyterlab_apod. It looks like the first “answer” in that repo corresponds to a bit later in the tutorial: GitHub - jupyterlab/jupyterlab_apod at 3.0-01-show-a-panel

Thanks for responding Jason.

There were no errors, simply the extension did not load the way the tutorial indicated it would.
I have tried from scratch twice.

The Read the docs tutorial
Sets up the conda environment with

conda create -n jupyterlab-ext --override-channels --strict-channel-priority -c conda-forge -c anaconda jupyterlab=3 cookiecutter nodejs jupyter-packaging git

Whereas in the github example uses the command:

conda env create

Pulling from the config file environment.yaml to install:

name: jupyterlab-extension-examples
  - conda-forge
  - jupyter-packaging>=0.7.9,<0.8.0
  - jupyterlab=3
  - nodejs
  - pytest
  - pytest-check-links
  - python=3
  - yarn

The differences in these dependencies appears to the reason that the tutorial does not work and the Github example does