Jupyterlab code is missing

Instead of code I see only lines. the whole code disappeared.
I use Jupyterlab 3.1.7

JL code

Please upgrade to the latest 3.1.x release. A bug like this has been fixed in a later release.

1 Like

thank you. I updated Jupyterlab and now it works.
How can I see the installed version with conda or in Jupyterlab itself?
thank you

@patite you can see the version in the About dialog (Help > About JupyterLab):



I have the latest Jupyter version 3.1.7 but I discovered that at one place the code disappeared.
I see lines instead of code.
The bug is still present but in a lower extend.JL_missing

Thank you for your answer.
Your version is 3.1.13. After updating Jupyterlab I get verstion 3.1.7.
Why I don’t get 3.1.13?
Where can I see in internet what is the latest version?
Why not integrating an automatic update in Jupyterlab like it is the case in many softwares?

You can see the list of released versions on PyPI for instance: jupyterlab · PyPI

When installing Jupyterlab with either
conda install -c conda-forge jupyterlab or
pip install jupyterlab or
conda update jupyterlab

I only get the version 3.1.7 and not 3.1.17 which is the official latest release.
Why is that?
thank you

I tried conda install -c conda-forge jupyterlab = 3.1.17 and it worked.

Logically when using conda update jupyterlab I should get version 3.1.17 but I get only 3.1.13!