Jupyterlab and Jupyter notebook don't recognize Google Drive folder

I reinstalled Anaconda because I couldn’t update my Jupyterlab to the latest version, which was required to install some extensions. But after reinstallment, I still can not install extensions. In addition, Jupyter doest recognize my Google Drive folder (stream files, with some offline files, I used to work with them before reinstalling Anaconda).
I noted my problems in details:

  1. I can not see my Google Drive folder from Jupyter’s File Browser. I still see it from MacOS Files. I tried to copy my Google drive path /Volumes/GoogleDrive to open in Jupyter’s File Browser, but it didn’t work.

  2. Anaconda is showing Jupyter lab 3.4.4 (see photo), but from the terminal, my version is 3.0.16. I can’t install any extension as Jupyter said the minimum version was 3.5.

[![enter image description here][1]][1]

jupyter core     : 4.7.1
jupyter-notebook : 6.4.0
qtconsole        : not installed
ipython          : 7.24.0
ipykernel        : 5.5.5
jupyter client   : 6.1.12
jupyter lab      : 3.0.16
nbconvert        : 6.0.7
ipywidgets       : not installed
nbformat         : 5.1.3
traitlets        : 5.0.5

I am using a MacBook pro rentina 2013 with macOS Big Sur.

Please give me some suggestions.
Many thanks in advance!


did you try to run your jupyter from /Volumes/GoogleDrive ?

Hi @erkin98 , I have tried like that by copying that path to Jupyter lab, but it said there was no path existing.
Another problem is the version. Although anaconda showed Jupyter lab version 3.4.4 but from the terminal, I saw version 3.0.16.

are you using same env for starting jlab and running above command for getting versions?

maybe you want to use google colab

I didn’t check the environment, I guess that could be the issue. I used to use Jupyter lab to work with some offline files on Google Drive, and that worked well. Now I think I have to install Jupyterlab completely because I got Installation failed after reinstalling. Do you have any suggestions @erkin98? I hope I don’t make it more complicated :sweat_smile:

remove all your conda envs create one with python 3.10 install latest version of jupyterlab

do you have envs rather than conda?

Hi @erkin98, in the end, it worked.
I uninstalled Anaconda and removed all related files. I also uninstalled Python.
I did install both the latest versions of Anaconda and Python.
I appreciate your help!

Hi again @erkin98, I tried to install Jupyterlab extensions by clicking on the extensions tab and got the message. How could I install extensions properly?

within your env run conda install -c conda-forge nodejs, and try again, if no success, try installing over pip