Jupyter / python graph display size

Hello there !

So i would like to fix an issue i have when i want to display multiple graph on python from jupyter notebook.

Let me show you how it is first with a sceenshot and then how i would like it to be with a second picture :
Picture 1)

As you can see on this first screenshot, i have all my graph in a separated “block” wich i can scrolldown with the “cursor” i show you in the red circle.

I would like this to not work this way but to have all graph and normally scroll down like we do to see all entry lines for exemple

Picture 2) Screenshot - df5f6f5a4a9d412606455a53ca79094a - Gyazo

Do you know any way to fix this for example with a code in python
(the main goal is to see everything in the entire screen)

Any answer would be greatly appreciated

You generally just left-click in space to the left side of the plots but in the box and it will expand to show all.

If you save the notebook and look in the code for the two versions, you’ll see this setting gets saved in the metadata for the cell. Here is when you need to scroll:

metadata": {
    "scrolled": true

Here is the code when it is expanded:

metadata": {
    "scrolled": false

Related extensions and options for the classic notebook may make your experience better, see here and the bottom of here.

Generally, JupyterLab is a better experience.
For an example, run this code in JupyterLab vs the classic notebook:

for n in range(165):

(If you don’t have JupyterLab installed, you can run it in your browser without needed to install anything by going here and clicking launch binder to spin up a temporary session served by the MyBinder service.)

You’ll see with JupyterLab, the output has no scrollbars added. In the classic notebook the mode with scrollbars get triggered automatically with output that long and you need to toggle them back off by left-clicking just to the left side of the list of numbers.

With JupyterLab you can opt in to the scrolling output by selecting output and right-clicking on it and selecting Enable ... or Disable Scrolling for Outputs.