Jupiter Notebook python.Exe error

I was hoping I could get some help as I’ve tried a couple solutions.

So to start off, I can open anaconda and Jupiter normally on my system, albeit when I try to close Jupyter as well as the CMD window, I get bombarded with the error “python.exe was unable to start correctly (0xc0000142)” , when I click close on the pop up, it instantly replaces that window with a new one. I’m thinking it could be some sort of malware that has caused this (albeit I don’t know where from). I’m forced to restart my system so that I can get the pop up to disappear.

Please help

I have the same problem. I have Windows 11 Pro with Kaspersky and this happened ever since I upgraded everything in Anaconda.

Ive been having the smae issue

So far I havent figure out whats causing it BUT there is a way to quit the endless pop up chain.

Fair warning though save everything involved with the notebooks before doing the below.

While youve got the error message on screen:
- instead of shutting down your computer you can open task manager
- go to the details pane of task manager
- You should see a “python.exe” with the jupyter notebooks logo
- left click on this and choose “End Process Tree”

You should be free of the pop ups now.

I am still looking into whats causing it, if I figure it out i will let you know.

If you dont mind replying to this;

  1. Do you have anaconda or any other package manager installed with the jupiter

@LaMpR were you able to update your anaconda Navigator to 2.3.2?

I have anaconda

I have found a way of preventing the infinite pop up.

By busting closing the kernel by either “ctrl double tap c” , or by quitting in the jupyter interface. It seems there is some issue with the kernel shutting down python when you just force close them.


So, for me it’s not forever, but 5-10 times. I do have Anaconda Navigator 2.3.2 and I am trying to update my Python to 3.9.15 since I had 3.8.x something, but it’s looking for conflicts for about 20h at this point :slight_smile:

Tried installing python with

conda install python=3.9.15

I can only try after that and see if this is finished somehow.

Weirdly I’m not even closing it myself, its just crashing and taking me to that infinite pop up. Spyder has crashed several times as well.

Have you tried to update python to 3.9.15 as @LaMpiR suggested?

Jeez, at this point if it was me I would uninstall Anaconda Navigator and re-install it so it brings python 3.9 and then use conda to update to 3.9.15

I was able to update it with no issues doing it that way.

So, I have removed anaconda all together. Removed python as well. Install python 3.11. Installed with pip notebook and I have the same error now. I don’t know what else to try :confused: