Jupyter Notebook won't open via Anaconda anymore

I used to have Jupyter Notebook as an icon pinned to my taskbar, it would launch just fine. Suddenly this morning, the icon has turned into an icon depicting a white page, and when I launch, a terminal opens up for a split second and disappears, and nothing happens after. Any thoughts?

Do you have the Anaconda Navigator still working? Can you open that first and then open from inside?

1 Like

Thanks for responding. I never had Anaconda Navigator for some strange reason. I tried launching Jupyter Notebook through my terminal and that doesn’t work either, though I’m not sure it ever worked.

Your post title says “via Anaconda”. The Navigator is included in the Anaconda distribution, see here. Maybe you meant minconda?

1 Like

No info about what operating system, version or anything makes it hard to provide support.

On… whatever you are running, try launching a command prompt, activating the conda environment you expect, and running:

jupyter notebook --no-browser --debug

then opening the link it (hopefully) provides in a new private browser.

Failing that, have a look at the output of stuff like:

conda list --explicit
pip freeze

And see if anything looks off.


Yes I believe it is Miniconda not Anaconda, although the icon shows up in my Windows Start under “Anaconda3” so not 100% sure. I use Anaconda on another machine and it opens up a whole menu with lots of features, I believe that is what you’re referring to, however on this machine in question I was never able to get the full fledged Anaconda (it’s a company laptop).

Thanks for your response. I am using Windows 10 and I am using Anaconda Prompt (Miniconda3) to run your suggestions.

The first prompt you gave me says “jupyter is not recognized as an internal or external command, operable program or batch file.”

The second prompt you gave me spit out a bunch of lines, I am not sure how to interpret them.

Thank you so much for taking the time to respond. I googled the error I was getting (“jupyter is not recognized as an internal or external command, operable program or batch file") and found a solution

if i prompt “python -m notebook” it opened!

1 Like

Yes, here says that Jupyter isn’t included by default with miniconda.

@miltongoldman, could you please update your text to link to the solution you found. Maybe it was here?

1 Like

All, I found the solution here after googling my error message (should’ve thought of this first!)