Is it possible to launch a repository of Jupyter Notebooks, but have the link open in a specific notebook rather than the Home Directory?

My GitHub repository has a number of Jupyter Notebooks in it. I have a Binder badge so that people can launch it here, and that opens to the Home directory. I’m wondering if I can also create links for each notebook that will still launch the repository. I’m not sure if the URL’s I see when I’m using the repository will work for others. I know that I can launch individual notebooks on Binder, but my programs use data which is in a folder in the master branch of my repository, and when launched individually they have no path to follow to the data. Is there a way to launch the entire repository, but have the link open in a specific notebook, or do I just link to the Home page?

Yes, you can create links that open on a specific notebook of your repo. The directory hierarchy you set up in the repo will be respected so the relative path to any other file and directory remains. The notebook opens with it location in the path as the working directory. There even is an absolute path; however, I suspect from helping you with another question, you wouldn’t want to use that as you intend your notebooks to be used via multiple serving avenues so you inherit the early parts of the absolute path from the providing resource.

The page, where you can launch and get pasteable text for links or badges, let’s you specify a Path to a notebook file as you are filling out the form. You can then use the URL it generates. It follows a pattern where the path to the specific notebook relative the main directory follows ?filepath=.

(Note if you are using the JupyterLab 1.0 or greater interface you need to look into workspaces.)


Thank you for your prompt reply. I had not been able to find any examples of other people doing the same thing, and when I tried it the first couple of times it didn’t work. The notebook opened, but it couldn’t access the data. Perhaps I had a setting wrong on However, now manually adding ?filepath=(notebook name) after master in the link does work. I appreciate the help with this.