Error launching server

I can’t launch jupyter notebook from my github project. Maybe some error related to multiple kernel in my dockerfile? The project builds, but there’s an error while trying to lauch the server.

How were you hoping to specify your configuration to Binder?
Presently your Dockerfile does not look not compatible with Binder. See Building using a custom Dockerfile .

However, keep in mind that it is recommended for Binder to only use a Dockerfile as a last resort. Looking at your Dockerfile briefly, I believe you can do all that with requirements.txt, apt.txt and a postBuild file. Or perhaps environment.yml , apt.txt, and a postBuild file. (For example, I’ve used apt.txt in my own repos for installing Java jdk/jre.) You’d put those files in binder (or .binder) directory in the root directory of your repository. For testing it may help to start a new repo where you do the development so you don’t mess up your current one, assuming it works for other routes now. This is because it may take some trial and error to work out what takes priority for repo2docker (see the next paragraph) which is the tech converting your repo to work on

I believe to keep your present Dockerfile approach, you’ll want to create a directory called binder in your root directory of your repository and start a different, special Dockerfile that MyBinder will use there. However, I haven’t tested all the priority levels lately. See here and read the linked items for more about this. And you may need to test since it clearly says, “If a Dockerfile is present, all other configuration files will be ignored.” I believe though a .binder or binder subdirectory has priority over Dockerfile in root, but you should test.


I tested creating a .binder directory containing other dockerfile, it worked for the minimal dockerfile configuration (yes, it has priority over Dockerfile in root). Now I’ll try adding multiple kernels.

Thanks a lot for the help!

@fomightez Hello! Is it possible to identify why container doesn’t launch?
I have only these messages there:

Found built image, launching...
Launching server...
Launch attempt 1 failed, retrying...
Launch attempt 2 failed, retrying...

My binder link is following:

The problem was that I’ve forgotten to add exec "$@" in my start file. But it’s still unclear how to diagnose such issues

1 Like

Glad to hear you fixed it.
Yes, launching issues are inherently tricky to debug because it isn’t like building where you can use repo2docker locally to develop a build. It is always best to start with a working example from among the Binder examples that is closest to what you want to do and then start customizing it with your stuff. I don’t know if having your own Binderhub would have helped diagnosing in that case, but it is much more complex approach than starting with an already working backbone.