Dependency on a package needing GLIBC 2.28

I am trying to create a mybinder that uses a pip dependency on a package that requires GLIBC 2.28. Ideally, it would be nice if the package was built in a more flexible manner, but that is not possible at this time.

What can I do to make GLIB 2.28 available? I don’t understand if conda’s virtual environments can help, or if I should be looking for a docker image that uses GLIBC 2.28.

Any hints would be appreciated!

conda’s virtual environments can help

Very possibly. If the package in question is already on conda-forge (or could be made to be), using an environment.yml will “just work”, as those issues would hopefully have been resolved already at build time to be consistent with whatever the current baseline is.

Even if some dependencies might bring it along, it’s worth trying.

- conda-forge
- nodefaults
- python >=3.10,<3.11 # or whatever, best to be sure...
- deps-of-the-package-in-conda-forge
- pip
- pip:
  - the-package-in-question
1 Like

Thanks, @bollwyvl ! This is the right solution… I need to be able to assemble a conda version of the pip package.