Created new Python env in conda but can't see it in Jupyter

The title says it all. I’m on Win 10. I created a new env in conda and activated it. But when I go to the New menu in Jupyter I don’t see the choice to create a new Notebook using that environment.

Of course I went googling around and tried a bunch of suggestions. This seems to be a very common problem with Jupyter but there is no definitive instruction set for how to fix it. It seems like most people just kept trying things they found online until it worked (or they gave up).

Check out nb_conda_kernels, that helps with this specifically!

I have nb_conda_kernels installed in both my Python 3 and Python 2 environments and it doesn’t help.

Strangely, I think my corporate Avast virus shield might be blocking Python 2 but not Python 3. I’m working that angle too.

@bretforeman ah hmmm perhaps nb_conda_kernels isn’t installed in the environment where jupyter lab / notebook was installed, so it didn’t couple with it as it should? There are also some settings that one can make, and you can debug directly with what packages nb_conda_kernel detects. I’m writing quickly from my memory right now without finding references, hope it is a bit helpful anyhow.