Could not find path

JupyterLab fails to see all but one directory inside a folder


and throws “Could not find path: Desktop/Deep Learning/DL_Code/backup” if I attempt to change working directory to any unseen folder inside “DL_Code”, via browser URL or

Using 3.2.0 via conda install -c conda-forge jupyterlab on Windows 10

Any chance you are using OneDrive? That seems to cause Windows users a lot of confusion because the files aren’t actually local when they think they are.
Search ‘OneDrive’ among the posts here for some recommendations of settings to use if that happens to be involved.

Following up on what @yuuuzeee suggests below:
From within the notebook or Jupyter teminal you can explore what it sees using the tips in the middle of my answer here.

I think the easier way for him to check it out is by opening up a terminal session and try ‘ls’?

Good point. I edited my first response pointing them to using some unix commands from within Jupyter to check what it sees.

I am signed out of OneDrive.

I shortened the path in OP.

Okay, and the text-based terminal/console in your Windows system (DOS?) has prodapp and other things?

And if you start Jupyter without any other info, where does it open? Can you copy the contents of DL-Code to there and see them then?

Did you try the suggestion here and the one below it?

1 Like

could u give a screenshot of ur backup folder in ur file browser installed on ur Windows OS?

1 Like

text-based terminal

Sees everything

start Jupyter without any other info, where does it open?

The console’s default directory, C:\Users\OverL\

copy the contents of DL-Code to there and see them then?

This works

Did you try the suggestion here

This works, though think I tried it before. Problem is, if I have code paths configured with respect to a higher directory than the minimal I need to get Jupyter to see things, then I need to rewrite this code. I don’t see why Jupyter shouldn’t be able to see these folders, Python terminal and Spyder have no trouble.

I don’t follow, what’s the backup folder?

My problem is solved, I could open an Issue on Github if this is a bug (which it seems to be).

1 Like

But how is your issue different from no files or folders appearing when i launch jupyter notebook · Issue #5427 · jupyter/notebook · GitHub, which was closed?

It was closed yet it’s still an issue. These workarounds burden the user and shouldn’t be needed.