System Cannot find the path specified

Running JupyterLab Desktop on Win 10 pro, and while its able to perform all the basic Python commands, I am unable to perform any tasks that requires additional libraries.

When I try to install, I get the error message:
The system cannot find the path specified

I have tried uninstall/reinstall, and trying to manually direct the path to the bundled Python executable through the settings tab of [manage Python environments]
The listed environment seems to match what it needs, but the error message persists any time I try to install additional libraries.
Are there any additional steps or error traps I might be missing when specifying a Python install directory path?

Thanks for any help on the matter.

On the chance that one isn’t playing well, did you try creating a new environment following the instructions here where it says, “When creating new environments from registry you can choose the type of the environment (conda or venv) and enter additional packages to install.”

I don’t think there are any packages needed that aren’t already included in the default Python environment, since some coworkers have managed to use the workbook while using the default env and the same version of Jupyter.

I did create a new environment as per the instructions, though I’m not really sure how to implement it from the instructions in the guide.

Maybe they can show your there settings then? Or you can make a new user account on your machine and try a fresh install and compare to your current user account?

1 Like

I work with Eric. There are four of us at our company that are regularly using the JupyterLab Desktop program. We will NOT update the program because any new user that tries installing the latest software gets the “path not found” error, which causes none of the libraries to work, and therefore our notebooks will not work. I tried installing the latest version on my personal HP laptop computer and got the same error message. Is anyone else having similar issues with the latest version of this program?

Thank you for both following up on this.

Turns out the answer to that question is unfortunately very much ‘Yes’.
Since it seems very reproducible, I looked into it and it seems there is a related report about this here. (And at least one related bug report.)
The current workaround options I see put forth are:

  • to use an earlier version, specifically v4.0.12-1 from January 31st, as described here.
  • to create a new Python environment (using New environment option) and install the dependency there, see here.

Hopefully, one of those options is amenable for now. Since you are talking about not updating the other machines, maybe just using the older version will suffice until this is rectified.
Sorry, that I didn’t connect this earlier.

1 Like

I went along with solution 1, and installed version 4.0.12, and my issues seem have been resolved. It looks like there is some change in the pathing with the bundled Python package in later versions, and Jupyter struggles to find it.
This may be worth noting in a bug report for future updates, but regardless, thank you for your help in resolving this!

1 Like

This was very helpful to us, thank you for your response today.

You are welcome to add your observations at the first issue link I shared. (The second one is marked as closed.)

1 Like