Container engine initialization error?

I have created a tiny repository here:


I have tried to follow the most basic example given in your tutorial. I am using a trivial requirements.txt file with only one dependency. I have placed this file within the root directory of the project. Binder waits for minutes before it prints

Waiting for build to start...

Container engine initialization error: ('Check if docker is running on the host.', DockerException("Error while fetching server API version: UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)"))
Failed to connect to event stream

I sense it’s something trivial I can’t see for the moment. Please help

It may have been a temporary glitch. It builds and launches fine now and import pycta works in a notebook.

I see you updated the version of Python specified in your package while I was trying it, but it was working before that change because the old commit from last night worked as well, as you can see by using:

Thank you for giving it a shot. It started to work without any significant changes to repo. That’s great. Meanwhile I have started to fill the binder cache (e.g. Docker registry) with a GitHub action, see cs/binder.yml at main · tschm/cs (
This is a great help to reduce the time needed to fire up Binder. Would Binder empty the cache after a few days/hours?

It is usually longer than that so that once it is built, it should be good for a while.