Can't save settings change to "max num of output cells" in Jupyter Notebook, reverts to 0

As of last week, I now have to click a message to expand JupyterHub notebook cell output. I’m using 3.4.3. Apparently this is a known bug that was fixed as of 3.2.5.

After running a cell with ANY output, the message says:

Output of this cell has been trimmed on the initial display. Displaying the first 50 top and last bottom outputs. Click on this message to get the complete output.

I believe this is a setting in *Settings > Advanced Setting > Notebook > " The maximum number of output cells to be rendered in the output area." (or just search “max” in the settings search box).
When I change the default “0" to anything else, such as 10, it reverts back to 0 after I close the settings tab and run a cell.
Entering “10” and then pressing “Return” does not move my cursor out of the field. Same for shift+return. I have to use my mouse to click somewhere outside of the field. I can then see that “10” is still set, but when I go to a notebook and run it, I see the “click me” message still.
I don’t see a way to save my edited setting.
I tried to stop the server, logout, log back in.
I must be missing something about how to save this setting change.

See this issue on:
StackOverflow
GitHub

It sounds like this is related to JupyterLab not JupyterHub, so I’ve updated the tags on this topic.

1 Like

Found a workaround for now:

  1. Click on Settings → Advanced Settings Editor
  2. On the top right, click on JSON Settings Editor. This will open two tabs: System Defaults and User Preferences.
  3. Under User preferences where the green {} are, copy and paste:
{
"maxNumberOutputs": 100000
}
  1. Click on Save. Refresh the notebook. Now when you run cells in the notebook, the trimmed cell output won’t show.